httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 33892] - mod_include: Slashes in regexps need to be escaped
Date Fri, 14 Jul 2006 01:29:30 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=33892>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=33892


theant@nodivisions.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |theant@nodivisions.com




------- Additional Comments From theant@nodivisions.com  2006-07-14 01:29 -------
This is currently marked as a Mac bug, but it affects Linux/x86 as well.  (Maybe
the re-assignment as a docs bug makes that irrelevant?)

For example if you have test.shtml, and you visit it as test.shtml?5, and it
contains this (HTML comment brackets stripped):

#if expr="$REQUEST_URI = /test.shtml\?5/"

...then the match fails, even though you can echo $REQUEST_URI to see that it
does contain the ?5 on the end.  But if you add the extra slash:

#if expr="$REQUEST_URI = /test.shtml\\?5/"

...then it matches.  Maddening!


-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message