httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 39737] - LogFormat "%{tid}P" reports wrong thread id on Windows
Date Tue, 13 Jun 2006 15:36:42 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=39737>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=39737





------- Additional Comments From gaodebin@hotmail.com  2006-06-13 15:36 -------
Anyone cares to comment on this?

Thread Ids are unique throughout the system, while handles are only unique
within the process.

It's really a pain not getting the thread id from the logs.  All I'm trying to
do is to find the corresponding thread that served the requests.  I can easily
obtain thread ids of all the threads; I can also get a handle to any thread, but
the integer value of that handle I obtain is different from what's been logged
by http, because the handles to the same thread could be different.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message