httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 39749] - Content-disposition filename is not working correctly
Date Fri, 09 Jun 2006 02:23:11 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=39749>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=39749





------- Additional Comments From rbaily@servicebench.com  2006-06-09 02:23 -------
Ok, thanks for the push in this direction.  I've done more research and seem 
to be at the root of the problem which looks like it was a combination of 
configuration mistake on my part and IE behavior.  I apologize now if I've 
wasted anyone's time.

Here are snapshots using tcpdump for 2.0.48 and 2.0.58.

Date: Fri, 09 Jun 2006 01:43:08 GMT
Server: Apache/2.0.58 (Unix) mod_ssl/2.0.58 OpenSSL/0.9.7d mod_jk/1.2.15
Content-Disposition: attachment;filename="test_file_name.xls"
Expires: 0
Cache-Control: must-revalidate, post-check=0, pre-check=0
Vary: Accept-Encoding,User-Agent
Content-Encoding: gzip
Keep-Alive: timeout=15, max=100
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: application/vnd.ms-excel

a
..........

21:38:10.448716 IP devbox2.servicebench.com.http > 
cheetah.servicebench.com.2156: P 1:421(420) ack 455 win 6432
E....)@.@.x[
..w
../.P.l...i=...P.. ....HTTP/1.1 200 OK
Date: Fri, 09 Jun 2006 01:38:10 GMT
Server: Apache/2.0.48 (Unix) mod_ssl/2.0.48 OpenSSL/0.9.7d mod_jk/1.2.15
Content-Disposition: attachment;filename="test_file_name.xls"
Expires: 0
Cache-Control: must-revalidate, post-check=0, pre-check=0
Content-Length: 20
Vary: User-Agent
Keep-Alive: timeout=15, max=100
Connection: Keep-Alive
Content-Type: application/vnd.ms-excel

0
12345678900987654321

I have the mod_deflate module active.  So what happened is that our 
configuration had the regex in there for IE (BrowserMatch \bMSIE !no-gzip !
gzip-only-text/html) which according to some other text did not work due to a 
bug in mod_setenvif up to 2.0.48.  So as you can see from the captures the 
content was not being compressed in 2.0.48 but was in any version after due to 
the mod_setenvif fix.  I did find that this does work for Firefox even with 
the compression.  So it appears that there is an ongoing issue with the way 
that IE handles the content-disposition when the result is compressed.

So I don't know if there is a good way to document this for future reference 
for other.  I'll see if I can do anything to start the Micorsoft machine in 
motion if that is even possible.  Again, sorry if this wasted anyone's time.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message