httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 38958] New: - Apache fails to build, saying mod_so cannot be used on this system (Slackware Linux 10.2 kernel 2.6.15.4)
Date Tue, 14 Mar 2006 03:02:28 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=38958>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=38958

           Summary: Apache fails to build, saying mod_so cannot be used on
                    this system (Slackware Linux 10.2 kernel 2.6.15.4)
           Product: Apache httpd-2
           Version: 2.0.55
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: major
          Priority: P1
         Component: Build
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: mail@martinjgreen.me.uk


I try to build apache2 (same problem with both 2.0.55 and 2.2.0) on Slackware 
using kernel 2.6.15.4 with configure options:

CFLAGS="-O2 -pipe -march=pentium4 -mtune=pentium4 -fomit-frame-pointer" 
CXXFLAGS=$CFLAGS \
./configure \
--enable-layout=Slack \
--enable-modules=most \
--enable-so \
--disable-cgid \
--disable-speling \
--disable-ldap \
--disable-proxy \
--enable-rewrite=shared \
--enable-include=shared \
--enable-ext-filter=shared \
--enable-env=shared \
--enable-expires=shared \
--enable-headers=shared \
--enable-setenvif=shared \
--disable-dav \
--disable-status \
--disable-info \
--enable-asis=shared \
--enable-vhost-alias=shared \
--enable-imap=shared \
--enable-actions=shared \
--enable-mime-magic=shared \
--enable-ssl=shared >> /root/apache.build

Configure fails with error:
configure: error: mod_so has been requested but cannot be built on your system

I've also tried compiling APR (downloaded separately from apache.org) and I 
get the same error telling me DSO support is not available.

Please note: I have a pre-built slackware binary package installed and working 
perfectly with shared modules. Its only the compile which has problems.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message