httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 38848] - httpd -X option broken
Date Sun, 05 Mar 2006 02:51:32 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=38848>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=38848





------- Additional Comments From rooneg@electricjellyfish.net  2006-03-05 03:51 -------
I was playing around with this, and I can "fix" the problem with the following
change:

Index: server/mpm/prefork/prefork.c
===================================================================
--- server/mpm/prefork/prefork.c        (revision 383230)
+++ server/mpm/prefork/prefork.c        (working copy)
@@ -536,7 +536,7 @@

     bucket_alloc = apr_bucket_alloc_create(pchild);

-    while (!die_now) {
+    while (!die_now && !shutdown_pending) {
         conn_rec *current_conn;
         void *csd;


I'm not sure if this is correct though, and I'm not sure when this problem
started.  svn blame and poking around areas of the code related to die_now and
shutdown_pending didn't show any particularly promising changes, mostly stuff
from way the hell back in the day.

Didn't try to fix the problem on non-prefork MPMs, but I do recall noticing it
with worker a while back.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message