httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 38805] - Undefined symbols ld error on apache 1.3.34 build on AIX 5.3 using gcc in 64 bit mode
Date Fri, 03 Mar 2006 03:17:39 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=38805>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=38805


bpinch@csc.com.au changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|REOPENED                    |RESOLVED
         Resolution|                            |WORKSFORME




------- Additional Comments From bpinch@csc.com.au  2006-03-03 04:17 -------
following the apache 1.3 on aix 
http://people.apache.org/~trawick/apache13aix.html note gave
# find / -name "libgcc.*" -print
./opt/freeware/lib/gcc-lib/powerpc-ibm-aix5.3.0.0/3.3.2/libgcc.a
./opt/freeware/lib/gcc-lib/powerpc-ibm-aix5.3.0.0/3.3.2/ppc64/libgcc.a
./opt/freeware/lib/gcc-lib/powerpc-ibm-aix5.3.0.0/3.3.2/pthread/libgcc.a
./opt/freeware/lib/gcc-lib/powerpc-ibm-aix5.3.0.0/3.3.2/pthread/ppc64/libgcc.a

So somethings similar to the following were tried including just one -lgcc

#EXTRA_LDFLAGS_SHLIB="-b64 -L/opt/freeware/lib/gcc-lib/powerpc-ibm-
aix5.3.0.0/3.3.2 -lgcc -L/opt/freeware/lib/gcc-lib/powerpc-ibm-
aix5.3.0.0/3.3.2/ppc64 -lgcc -L/opt/freeware/lib/gcc-lib/powerpc-ibm-
aix5.3.0.0/3.3.2/pthread -lgcc -L/opt/freeware/lib/gcc-lib/powerpc-ibm-
aix5.3.0.0/3.3.2/pthread/ppc64  -lgcc"; export  EXTRA_LDFLAGS_SHLIB; echo 
$EXTRA_LDFLAGS_SHLIB


The ld error remained in that the symbol remained unresolved.

However, adding to the still undefined symbol to __fixunssfdi (there was only 
one) to src/support/httpd.exp as explained in 
http://people.apache.org/~trawick/apache13aix.html allowed apache to link and 
subsequently start as a webserver.

Thanks
Brian








-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message