httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 38651] New: - make failed with libapr link error
Date Wed, 15 Feb 2006 06:51:59 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=38651>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=38651

           Summary: make failed with libapr link error
           Product: Apache httpd-2
           Version: 2.0.55
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: blocker
          Priority: P2
         Component: Core
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: legerf@free.fr


Under Debian Sarge/stable, with packages libldap2 libldap2-dev libsasl2
libssl-dev, I try to compile Apache 2.0.55 without patch.

I configure with success "./configure --prefix=/usr/local/httpd
--enable-auth-digest  --enable-auth-ldap  --enable-expires --enable-ldap 
--enable-logio --enable-ssl".
After I launch "make" with success too.
But the "make install" failed. Detailed of error :
joshua5:~/install/Apache-2.0.55/httpd-2.0.55# make install
Making install in srclib
make[1]: Entering directory `/root/install/Apache-2.0.55/httpd-2.0.55/srclib'
Making install in apr
make[2]: Entering directory `/root/install/Apache-2.0.55/httpd-2.0.55/srclib/apr'
/bin/sh /root/install/Apache-2.0.55/httpd-2.0.55/srclib/apr/libtool --silent
--mode=link gcc -g -O2 -pthread -DHAVE_CONFIG_H   -DLINUX=2 -D_REENTRANT
-D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE -D_GNU_SOURCE -I./include
-I../include -version-inf  o 9:7:9 -o libapr-0.la -rpath /usr/local/httpd/lib
strings/*.lo passwd/*.lo tables/*.lo file_io/unix/*.lo network_io/unix/*.  lo
threadproc/unix/*.lo misc/unix/*.lo locks/unix/*.lo time/unix/*.lo
mmap/unix/*.lo shmem/unix/*.lo user/unix/*.lo memory/u  nix/*.lo
atomic/unix/*.lo poll/unix/*.lo support/unix/*.lo dso/unix/*.lo -lrt -lm -lcrypt
-lnsl -lpthread -ldl
libtool: link: `strings/*.lo' is not a valid libtool object
make[2]: *** [libapr-0.la] Error 1
make[2]: Leaving directory `/root/install/Apache-2.0.55/httpd-2.0.55/srclib/apr'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/root/install/Apache-2.0.55/httpd-2.0.55/srclib'
make: *** [install-recursive] Error 1

So I try to recompile "./Apache-2.0.55/httpd-2.0.55/srclib/apr-util" and
"./Apache-2.0.55/httpd-2.0.55/srclib/apr" without error.

When I search all libapr files, I find :

./Apache-2.0.55/httpd-2.0.55/srclib/apr-util/libaprutil.dsp
./Apache-2.0.55/httpd-2.0.55/srclib/apr-util/libaprutil.rc
./Apache-2.0.55/httpd-2.0.55/srclib/apr-util/.libs/libaprutil-0.so.0.9.7
./Apache-2.0.55/httpd-2.0.55/srclib/apr-util/.libs/libaprutil-0.so.0
./Apache-2.0.55/httpd-2.0.55/srclib/apr-util/.libs/libaprutil-0.so
./Apache-2.0.55/httpd-2.0.55/srclib/apr-util/.libs/libaprutil-0.a
./Apache-2.0.55/httpd-2.0.55/srclib/apr-util/.libs/libaprutil-0.lai
./Apache-2.0.55/httpd-2.0.55/srclib/apr-util/.libs/libaprutil-0.la
./Apache-2.0.55/httpd-2.0.55/srclib/apr-util/libaprutil-0.la
./Apache-2.0.55/httpd-2.0.55/srclib/apr/libapr.rc
./Apache-2.0.55/httpd-2.0.55/srclib/apr/build/libapr_app.dsp
./Apache-2.0.55/httpd-2.0.55/srclib/apr/libapr.dsp
./Apache-2.0.55/httpd-2.0.55/srclib/apr/libaprnw.mcp.zip

Why the libapr doesn't create correctly ?

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message