httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 38195] - Build system not respecting -static-libgcc flag
Date Thu, 12 Jan 2006 13:08:24 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=38195>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=38195


jorton@redhat.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|REOPENED                    |RESOLVED
         Resolution|                            |INVALID




------- Additional Comments From jorton@redhat.com  2006-01-12 14:08 -------
> In the build typescript the '-static-libgcc' was being passed to libtool, not
directly to gcc in all cases 
> except the final httpd binary link. Could it be possible that libtool doesn't
pass this flag to gcc?

Yes, that is quite possible.  I notice you are passing -m64 in CFLAGS; that is
not a good idea either.

Here is what I would try if the LDFLAGS trick did not work:

CC="gcc -mcpu=v9 -m64 -static-libgcc" ./configure ...etcetc

if that does not work either please report the issue to bug-libtool@gnu.org, the
httpd build system is driving libtool correctly AFAICT; LDFLAGS is also
propagated through the buildsystem correctly, so I can't see any httpd bug that
can be fixed.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message