httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 37352] New: - Reverse proxy does not work on AIX 5.2
Date Fri, 04 Nov 2005 07:40:36 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=37352>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=37352

           Summary: Reverse proxy does not work on AIX 5.2
           Product: Apache httpd-2.0
           Version: 2.0.53
          Platform: Other
        OS/Version: AIX
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_proxy
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: ltg@zes.uni-bremen.de


Hi,

I compiled Apache 2.0.53 with gcc 3.4.4 on AIX 5.2.

This is the error message I got in the log file:

  [Fri Nov 04 08:09:47 2005] [warn] proxy: No protocol handler was valid for the
  URL /. If you are using a DSO version of mod_proxy, make sure the proxy
  submodules are included in the configuration using LoadModule.
  [Fri Nov 04 08:09:47 2005] [debug] mod_proxy.c(418): Trying to run
  scheme_handler

This is the error I get when I try to access the server being proxyied:

  Forbidden

  You don't have permission to access / on this server.
  Apache/2.0.53 (Unix) PHP/4.3.11 mod_ssl/2.0.53 OpenSSL/0.9.8 DAV/2 Server at
  bbb.aaa.aaa.aaa Port 80

When I access bbb.aaa.aaa.aaa directly it displays without (noticeable) 
problems.


This is a part of my config file:

  <virtualHost 134.102.3.1:80>
        ServerName bbb.aaa.aaa.aaa
        ServerAlias ccc.aaa.aaa.aaa
        DocumentRoot /dir1/dir2/dir3
        DirectoryIndex startHere.html index.html Welcome.html
        ServerAdmin admin@aaa.aaa.aaa

        ErrorLog /dir4/dir5/dir6/file1
        TransferLog /dir4/dir5/dir6/file2

        <Directory /dir1/dir2/dir3 >
                AllowOverride AuthConfig
        </Directory>

        <IfModule mod_proxy.c>
                ProxyRequests Off
                <Proxy *>
                        Order deny,allow
                        Allow from all
                </Proxy>
                ProxyPass        /      http://ddd.ddd.ddd:8080/
                ProxyPassReverse /      http://ddd.ddd.ddd:8080/
        </IfModule>
</VirtualHost>

I loaded all proxy submodules in httpd.conf (and all other modules built
when using the "all" keyword).


Does anybody has a clue what went wrong here?

Thanx in advance,
Lothar

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message