httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 37051] New: - Mod_SSL warning Init: SSL server IP/port conflict.
Date Wed, 12 Oct 2005 15:35:13 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=37051>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=37051

           Summary: Mod_SSL warning Init: SSL server IP/port conflict.
           Product: Apache httpd-2.0
           Version: 2.0.54
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: minor
          Priority: P2
         Component: mod_ssl
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: graham@wyenet.net


I am building 64bit Apache 2.0.54, with shared libraries, and SSL enabled, the 
application builds without any problems, but when running the server the 
following errors appear in the error log.

My OpenSSL is 0.9.8, but I have applied the patch to Mod_SSL which allows this 
version of OpenSSL to work.

[Wed Oct 12 16:24:19 2005] [warn] Init: SSL server IP/port conflict: 
www.philipm
orris.uk.com:443 (/etc/httpd/conf/ssl.conf:280) vs. www.queenswood.co.uk:443 
(/e
tc/httpd/conf/ssl.conf:306)
[Wed Oct 12 16:24:19 2005] [warn] Init: SSL server IP/port conflict: 
www.crowsfe
et.net:443 (/etc/httpd/conf/ssl.conf:254) vs. www.queenswood.co.uk:443 
(/etc/htt
pd/conf/ssl.conf:306)
[Wed Oct 12 16:24:19 2005] [warn] Init: You should not use name-based virtual 
ho
sts in conjunction with SSL!!
[Wed Oct 12 16:24:19 2005] [notice] Apache/2.0.54 (Unix) PHP/5.0.5 
mod_ssl/2.0.5
4 OpenSSL/0.9.8 DAV/2 configured -- resuming normal operations

I have compiled Apache under Solaris 9, with GCC 3.4.2, and also in Solaris 10 
with GCC 3.4.2, and with Sun Studio 10, and in every instance I've had the 
errors in the log. (System is a Netra T1/AC200 with a 500mhz Ultrasparc IIi 
CPU)

It's a minor problem, as the server continues, and it correctly links my IP 
Virtual SSL sites to their correct certificates without any problems, it 
appears to just be a logging issue.

If I switch to a 32bit build, then there is no problem, the SSL warning is 
gone, and everything works fine, but I wish to use the 64bit build to get 
around the STDIO limit of 255 open files that Solaris has.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message