httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 36816] - BalancerManager interface doesn't work if BalancerMember has port or path
Date Wed, 05 Oct 2005 18:29:55 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=36816>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=36816





------- Additional Comments From cmurtaugh@yahoo.com  2005-10-05 20:29 -------
Upon further investigation, I see that in the balancer_manager interface, the
worker->hostname is used to identify each worker.  However, the worker should be
identified by worker->name (which includes the port number).  

In my previous example, if I click on the hostname of the first worker in the
balancer manager, the URL should contain: 'w=my.server.com:1234' (instead of
'w=my.server.com' as it does now).  Also, the value of the 'w' hidden field in
the 'Edit worker' form should contain 'my.server.com:1234'. 

I've attached a patch to mod_proxy_balancer.c that makes that change, and seems
to fix the problem.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message