httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 36908] New: - SetEnvIf doesn't see SetEnv variables
Date Tue, 04 Oct 2005 11:09:41 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=36908>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=36908

           Summary: SetEnvIf doesn't see SetEnv variables
           Product: Apache httpd-2.0
           Version: 2.0.54
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: minor
          Priority: P2
         Component: mod_setenvif
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: vladap@criticalpublics.com


The following will not work:
SetEnv evh_lang=gr
SetEnvIf host ^opeportal-en evh_lang=en
SetEnvIf host ^www-en.kerasma evh_lang=en
SetEnvIf host ^www.kerasma.com evh_lang=en

SetEnvIf evh_lang gr vhlog_gr
SetEnvIf evh_lang en vhlog_en

vhlog_gr will never be set, only vhlog_en. It seems that SetEnvIf ignores SetEnv
variables. In order for this to work, first line should be:

SetEnvIf host ^[a-z] evh_lang=gr

which is not very nice.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message