httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 34943] - util_ldap.c: In function `util_ldap_connection_open':
Date Mon, 26 Sep 2005 03:41:46 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=34943>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=34943





------- Additional Comments From stella@rider.edu  2005-09-26 05:41 -------
(In reply to comment #7)
> HTTPD 2.0.54, in include/apr_ldap.h I tried to do:
> 
> #else /* APR_NOT_READY_YET */
> 
> /* FIXME: remove this when above code works.  Default to build with
>  * OpenLDAP until apu-conf.m4 support exists */
> #define APR_HAS_OPENLDAP_LDAPSDK 0
> define APR_HAS_NETSCAPE_LDAPSDK 1
> #define APR_HAS_NETSCAPE_LDAPSDK 1
> #define APR_HAS_LDAP_SSL 1
> define APR_HAS_LDAP_SSL 1
> 


No no.. You don't uncomment 'defines'...  It should be:

/* FIXME: remove this when above code works.  Default to build with
 * OpenLDAP until apu-conf.m4 support exists */
#define APR_HAS_OPENLDAP_LDAPSDK 0
#define APR_HAS_NETSCAPE_LDAPSDK 1
#define APR_HAS_LDAP_SSL 1

It now compiles, but I get:

Syntax error on line 188 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/mod_ldap.so into server: /usr/local/apach
e2/modules/mod_ldap.so: undefined symbol: ldapssl_init






-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message