httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 36497] New: - Problem with Downloads, using Apache as Forward Proxy
Date Mon, 05 Sep 2005 11:23:12 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=36497>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=36497

           Summary: Problem with Downloads, using Apache as Forward Proxy
           Product: Apache httpd-2.0
           Version: 2.0.46
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_proxy
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: anil@cordys.com


Hi,
	 
I have posted many queries to Apache users mailing list but has not got any 
answers till now. I need to desperately get this issue solved. 

The issue is this:
        We are having Apache (version 2.0.54) installed as a forward proxy on 
RHEL 3.0. 
Downloads fail more often than being successful. 


The set up:
------------------
Apache as the Forward proxy,  which is in turn connected to Firewall. Users 
connect to Apache as Forward proxy.

Issue:
---------
Partial/incomplete Downloading of file. 
Download starts properly after some time it suddenly says download complete. 
Attempting to open the file, we get invalid/corrupt downloaded file alert.

For e.g.: 
    if we attempt to download 116MB , download stops after 10 MB (some time it 
went till 110MB).

When we directly connect to the web server, without Apache as a forward proxy, 
we get successful downloads 100%.

Error log:
-------------

The error log does not show anything in 2.0.54.

Using 2.0.48, we get 
	[notice] child pid 20653 exit signal Segmentation fault (11) and 
	[Fri Aug 12 15:02:51 2005] [notice] child pid 431 exit signal Abort (6)

If we use Apache 2.1.6 alpha:
        (104)Connection reset by peer: proxy: error reading response

We tested all the known versions of Apache 2.0 (2.0.48, 2.0.52, 2.0.54, 2.1.6 
alpha). Changed the OS to RHEL 4.0 but the problem persists.

Without Apache downloads are successful.

We need to get this solved as early as possible. Please do help us in this 
regard.

configuration of the HTTPD:
Note:
    The changed httpd.conf entries are as follows:

<IfModule worker.c>
StartServers       15
MaxClients        750
MinSpareThreads    25
MaxSpareThreads    750
ThreadsPerChild     50
MaxRequestsPerChild  0
#ServerLimit          10
MaxMemFree      2000
</IfModule>

#Apache as Proxy
ProxyRequests On


(Everything else is default conf file.)

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message