httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 34295] - CGI execution issue - stdin hung
Date Fri, 02 Sep 2005 15:20:38 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=34295>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=34295





------- Additional Comments From paran.umapathy@ca.com  2005-09-02 17:20 -------
As per my colleague's comment, I had already changed the code and tested this.

int cl = atoi(getenv("CONTENT_LENGTH");
char *buf = new char[cl+1];

fgets(buf, cl, stdin);
buf[cl+1]='\0';

When I debugged, it is waiting forever in fgets() call.

Also for testing puposes, I tried to read fewer chars like 5 chars, that also 
didn't work.

I read in the user groups that they are seeing this issue even in IIS. 
Microsoft now has strict rules to handle CGI post.

As I said before, the existing code works fine on unix platforms.


-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message