httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 36422] New: - x86/x64 Apache must throw an error message during installation of Apache HTTP Server if IIS website is running on same port.
Date Tue, 30 Aug 2005 15:23:54 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=36422>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=36422

           Summary: x86/x64 Apache must throw an error message during
                    installation of Apache HTTP Server if IIS website is
                    running on same port.
           Product: Apache httpd-2.0
           Version: 2.0.54
          Platform: PC
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Runtime Config
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: a-mickel@microsoft.com


1. Install Windows Vista ADS 5215 build.
2. Make sure your IIS website is running.(Go to Run>inetmgr>Default website)
3. Start installation of Apache HTTP Server 2.0.54.
4. Watch for any error message.
5. After completion of installation, try start, stop or restart of apache 
service through services.msc wizard or from Apache Application.
6. Watch for any error message.
7. Start and stop IIS Website through inetmgr. Watch for any error message.
8. Browse port 80 http://localhost:80. Observe that it displays the default 
website configured on the Apache server.
. Check which website it shows on browser.

Additional Notes:
By default, IIS Website Service is running on Longhorn. When Apache got 
installed on this machine, it does not pop an error to stop default IIS 
website. Apache gets installed and its service can start, stop or restart 
without an error. It is found that both the services use port 80 and both are 
in running mode.
Expected behavior of throwing an error message is observed on Windows 2003 
Server (1830).
When both IIS and Apache services are simultaneously running on the same 
machine with websites using port 80 in both cases, and when we try to browse 
http://localhost:80  we get the Apache website.

Results: Apache does not detect the existence of an IIS server on the same 
machine. Apache does not throw any error message during installation when IIS 
website is running on same port. System does not throw an error message when 
starting and stopping either of the services.

Expected Results:  Apache must throw an error message during installation when 
IIS website is running on same port. Again, it must throw an error message 
when starting and stopping either of the services.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message