httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 36065] New: - cgi image data not passed to browser under windows xp
Date Sun, 07 Aug 2005 17:30:10 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=36065>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=36065

           Summary: cgi image data not passed to browser under windows xp
           Product: Apache httpd-2.0
           Version: 2.0.54
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_cgi
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: michael.stirling@gmail.com


Overview Description:
  Under windows XP a cgi script sends local image data to the server.
  The server fails to send this to the browser.

Steps to Reproduce:
1) make a new directory images/ in the cgi-bin directory

2) put an image in the new directory (eg. ..../cgi-bin/images/logo.png)

3) put this lua script in the cgi-bin directory. call it 'image-script'

#!c:\Program Files\Lua\BIN\lua
-- note: this script needs a working lua environment
do
  local raw=os.getenv("QUERY_STRING") -- info from GET request. ie url?info
  local file=io.open('images/'..raw,'r')
  if file then
    local data=file:read('*all') file:close()
    io.write('Content-type: image/jpg\n\n')
    io.write(data)
  end
end

4) make a web page that calls the script using this tag:
<img src="http://localhost/cgi-bin/image-script?logo.png">

Actual Results:
  Under windows xp, the image isn't passed by the server.
  The access.log contains "GET /cgi-bin/image-script?logo.png HTTP/1.1" 200 6
  so the server isn't passing on the data it recieves. 
  The error.log reports no errors.

Expected Results:
  I expect it to work the same as under debian-linux with Apache/1.3.33.
(the data should be passed to the browser, which should then display an image)

Build Date & Platform:
  Build 2.0.54 on Windows XP sp2

Additional Builds and Platforms:
  - Also Occurs On

  - Doesn't Occur On
  Apache 1.3.33 on Debian-Linux-ppc 2.4.20

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message