httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 35757] New: - Doesn't compile with OpenSSL 0.9.8 (works with olders)
Date Fri, 15 Jul 2005 14:46:18 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=35757>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=35757

           Summary: Doesn't compile with OpenSSL 0.9.8 (works with olders)
           Product: Apache httpd-2.0
           Version: 2.0.54
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: blocker
          Priority: P2
         Component: mod_ssl
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: Laurent.Pellissier@ema.fr


I have updated the brand new OpenSSL 0.9.8 from sources as I do usually :

./Configure --prefix=/opt/openssl-0.9.8 linux-elf
make && make install

Then I've tried to update my Apache :

./configure --prefix=/opt/apache --mandir=/usr/share/man --enable-ssl
--enable-dav --enable-dav-fs –-enable-so --enable-rewrite
--with-ssl=/opt/openssl-0.9.8

/home/kermit/A_Sauver/httpd-2.0.54/srclib/apr/libtool --silent
--mode=compile gcc  -g -O2 -pthread    -DLINUX=2 -D_REENTRANT
-D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE -D_GNU_SOURCE
-DAP_HAVE_DESIGNATED_INITIALIZER
-I/home/kermit/A_Sauver/httpd-2.0.54/srclib/apr/include
-I/home/kermit/A_Sauver/httpd-2.0.54/srclib/apr-util/include
-I/home/kermit/A_Sauver/httpd-2.0.54/srclib/apr-util/xml/expat/lib -I.
-I/home/kermit/A_Sauver/httpd-2.0.54/os/unix
-I/home/kermit/A_Sauver/httpd-2.0.54/server/mpm/prefork
-I/home/kermit/A_Sauver/httpd-2.0.54/modules/http
-I/home/kermit/A_Sauver/httpd-2.0.54/modules/filters
-I/home/kermit/A_Sauver/httpd-2.0.54/modules/proxy
-I/home/kermit/A_Sauver/httpd-2.0.54/include
-I/home/kermit/A_Sauver/httpd-2.0.54/modules/generators
-I/opt/openssl-0.9.8/include/openssl -I/opt/openssl-0.9.8/include
-I/home/kermit/A_Sauver/httpd-2.0.54/modules/dav/main -prefer-non-pic
-static -c ssl_engine_pphrase.c && touch ssl_engine_pphrase.lo
ssl_engine_pphrase.c: In function `ssl_pphrase_Handle_CB':
ssl_engine_pphrase.c:684: `PEM_F_DEF_CALLBACK' undeclared (first use in
this function)
ssl_engine_pphrase.c:684: (Each undeclared identifier is reported only once
ssl_engine_pphrase.c:684: for each function it appears in.)
make[3]: *** [ssl_engine_pphrase.lo] Erreur 1
make[3]: Leaving directory `/home/kermit/A_Sauver/httpd-2.0.54/modules/ssl'
make[2]: *** [all-recursive] Erreur 1
make[2]: Leaving directory `/home/kermit/A_Sauver/httpd-2.0.54/modules/ssl'
make[1]: *** [all-recursive] Erreur 1
make[1]: Leaving directory `/home/kermit/A_Sauver/httpd-2.0.54/modules'
make: *** [all-recursive] Erreur 1


Apache compiles fine with OpenSSL 0.9.7e or even 0.9.7g but fails when I switch
to the 0.9.8.
This bug seems to have a solution :
http://mail-archives.apache.org/mod_mbox/httpd-dev/200507.mbox/%3c20050705123248.GE23007@2scale.net%3e

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message