httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 29189] - ap_log_error() with NULL server_rec lost after startup on Win32
Date Thu, 02 Jun 2005 22:30:58 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=29189>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=29189


eddiearmeen@yahoo.co.uk changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |eddiearmeen@yahoo.co.uk




------- Additional Comments From eddiearmeen@yahoo.co.uk  2005-06-03 00:30 -------
on httpd-2.0.54

server/log.c log_error_core 

if you pass a NULL server_rec then the code assumes you are in startup or 
shutdown and the only log level it displays is APLOG_NOTICE so if you do want 
to pass a NULL server_rec then using this will log it.

As far as I am aware this file is the same for unix and win32 - are the calls 
on unix using APLOG_NOTICE ?

Also you say it works during startup and shutdown but not during requests, but 
passing a NULL server_rec makes the code assume you are in startup or shutdown.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message