httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 34888] New: - mod_cache doesn't rebuild cache when reloading page
Date Thu, 12 May 2005 09:19:38 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=34888>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=34888

           Summary: mod_cache doesn't rebuild cache when reloading page
           Product: Apache httpd-2.0
           Version: 2.0.54
          Platform: Other
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_cache
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: apache@dimedis.de


We use Debian Sarge with Apache 2.0.54-2 prebuild in the debian repository.

mod_disk_cache config:

CacheRoot /cacheroot
CacheSize 1024
CacheEnable disk /
CacheDirLevels 5
CacheDirLength 3

mod_proxy was disabled for the test.

For this test we used a little testscript (cachetest.cgi):

#!/usr/bin/perl
use CGI;
use strict;
my $cachetime=60;
my $foo=localtime();
print "Expires: ".CGI::expires("+".$cachetime."s","http")."\n";
print "Date: ".CGI::expires(0,"http")."\n";
print "Last-Modified: ".CGI::expires(0,"http")."\n";
print "Cache-Control: max-age=$cachetime\n";
print qq(Content-type: text/html
<HTML>
<BODY>
$foo
);
sleep(5);
print qq(
Test
</BODY>
</HTML>
);

We cleaned up /cacheroot and restart apache.

When we first requested the cgi
lynx http://localhost/cgi-bin/cachetest.cgi

the document was cached. The next requests with lynx resulted in the correctly
cached version. After 60 seconds lynx got an new version and the cache rebuilded
as expected.

So far so good. 

BUT: When we request the cgi with
lynx --reload http://localhost/cgi-bin/cachetest.cgi

we see a non-cached version. Which is correct. But the cache is NOT rebuilded:
The next request with  lynx http://localhost/cgi-bin/cachetest.cgi gets the OLD
content of the cache. The reload of the browser only results in a temporarly way
through the cache to the most recent version. But it don't refresh the cache
itself. 

This behaviour (which is reproducable with Firefox - but easier and more obvious
with lynx) doesn't seem correct.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message