httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 34848] New: - mod_proxy_balancer leaves out URL arguments
Date Tue, 10 May 2005 17:55:59 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=34848>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=34848

           Summary: mod_proxy_balancer leaves out URL arguments
           Product: Apache httpd-2.0
           Version: 2.1-HEAD
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: major
          Priority: P2
         Component: mod_proxy
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: dohair@virtualiron.com
                CC: jorton@redhat.com


I may have found a bug in httpd-2.1.3-beta mod_proxy_balancer.  I have the 
proxy load balancer setup and working fine, until I pass this URL to Apache:

http://apachehost/someRedirectableUrl?arg=value

The URL that gets forwarded to the back-end server is missing the URL 
arguments.  The URL that gets passed to proxy_balancer_pre_request() already 
has the URL arguments stripped out, and they never get put back.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message