httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 34767] - Apache 2 startup gives unresolved external on HP UX11i with my custom module
Date Fri, 06 May 2005 12:23:52 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=34767>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=34767





------- Additional Comments From vivekg@noida.hcltech.com  2005-05-06 14:23 -------
First of all I don't have words to thank for this as now atleast I am able to 
see a better error indication rather than just a blunt message.
As suggested I tried with the changes, and now it indicates that some symbol 
not found and I am using it. But what can I do to resolve this issue as I 
suspect this to be a environment/build issue and not a issue of the code. And 
the same module works fine with apache 2.0 on Linux 3.0 and Solaris 9. Please 
suggest what could be the cause of the same or how can I go about resolving 
this issue.

$ ../bin/apachectl start
/usr/lib/dld.sl: Unresolved symbol: htons (code)  
from /home1/saurabhs/Apache/latest/modules/myModuleApache.so
Syntax error on line 232 of /home1/saurabhs/Apache/latest/conf/httpd.conf:
Cannot load /home1/saurabhs/Apache/latest/modules/myModuleApache.so into 
server: Unresolved external

$ ldd -r myModuleApache.so
        /usr/local/lib/libgcc_s.sl =>   /usr/local/lib/libgcc_s.sl
        /usr/lib/libc.2 =>      /usr/lib/libc.2
        /usr/lib/libdld.2 =>    /usr/lib/libdld.2
        /usr/lib/libc.2 =>      /usr/lib/libc.2
        /usr/lib/libc.2 =>      /usr/lib/libc.2
        symbol not found: _end  (/usr/lib/libc.2)
        symbol not found: _SYSTEM_ID    (/usr/lib/libc.2)
        symbol not found: htons (myModuleApache.so)
        symbol not found: __dld_loc     (/usr/lib/libdld.2)
        symbol not found: ap_log_error  (myModuleApache.so)
        symbol not found: apr_palloc    (myModuleApache.so)
        symbol not found: apr_table_get (myModuleApache.so)
        symbol not found: apr_pstrcat   (myModuleApache.so)
        symbol not found: apr_table_set (myModuleApache.so)
        symbol not found: apr_brigade_destroy   (myModuleApache.so)
        symbol not found: apr_table_elts        (myModuleApache.so)
        symbol not found: ap_hook_child_init    (myModuleApache.so)
        symbol not found: ap_get_server_port    (myModuleApache.so)
        symbol not found: ap_get_remote_host    (myModuleApache.so)
        symbol not found: ap_get_server_name    (myModuleApache.so)
        symbol not found: apr_pool_cleanup_register     (myModuleApache.so)
        symbol not found: ap_hook_fixups        (myModuleApache.so)
        symbol not found: ap_hook_translate_name        (myModuleApache.so)
        symbol not found: ap_hook_handler       (myModuleApache.so)
        symbol not found: ap_run_http_method    (myModuleApache.so)
        symbol not found: apr_brigade_create    (myModuleApache.so)
        symbol not found: ap_construct_url      (myModuleApache.so)
        symbol not found: apr_table_setn        (myModuleApache.so)
        symbol not found: ap_os_escape_path     (myModuleApache.so)
        symbol not found: apr_table_add (myModuleApache.so)
        symbol not found: apr_pstrdup   (myModuleApache.so)
        symbol not found: ap_rflush     (myModuleApache.so)
        symbol not found: ap_rwrite     (myModuleApache.so)
        symbol not found: apr_brigade_flatten   (myModuleApache.so)
        symbol not found: ap_get_brigade        (myModuleApache.so)
        symbol not found: pthread_mutex_unlock  (/usr/local/lib/libgcc_s.sl)
        symbol not found: pthread_mutex_lock    (/usr/local/lib/libgcc_s.sl)
        symbol not found: pthread_setspecific   (/usr/local/lib/libgcc_s.sl)
        symbol not found: pthread_getspecific   (/usr/local/lib/libgcc_s.sl)
        symbol not found: pthread_key_create    (/usr/local/lib/libgcc_s.sl)
        symbol not found: pthread_once  (/usr/local/lib/libgcc_s.sl)
        symbol not found: _SYSTEM_ID    (/usr/lib/libc.2)
        symbol not found: _SYSTEM_ID    (/usr/lib/libc.2)


-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message