httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 33488] New: - After compiling apache 2.0.53 it links to not existing libicon.so.2 library
Date Thu, 10 Feb 2005 11:35:12 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=33488>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=33488

           Summary: After compiling apache 2.0.53 it links to not existing
                    libicon.so.2 library
           Product: Apache httpd-2.0
           Version: 2.0.53
          Platform: PC
               URL: http://www.design.bg
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Build
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: hipo@design.bg


As I said, After a compilation of apache 2.0.53 on fedora core 1 ( with all
possible security upgrades ). The builded apache binary is linked for no reason
to a libiconv library and the httpd binary searches for the library in the same
directory where it is located. Here is a sample.
[root@design.bg httpd-2.0.53]# ldd .libs/httpd
        libz.so.1 => /usr/lib/libz.so.1 (0x002d0000)
        libaprutil-0.so.0 => /usr/local/apache2/lib/libaprutil-0.so.0 (0x0060a000)
        libgdbm.so.2 => /usr/lib/libgdbm.so.2 (0x00570000)
        libdb-4.1.so => /lib/tls/libdb-4.1.so (0x00d97000)
        libexpat.so.0 => /usr/lib/libexpat.so.0 (0x00b00000)
        libiconv.so.2 => not found
        libapr-0.so.0 => /usr/local/apache2/lib/libapr-0.so.0 (0x00eb0000)
        librt.so.1 => /lib/tls/librt.so.1 (0x00662000)
        libm.so.6 => /lib/tls/libm.so.6 (0x00923000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x00aa8000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x008e6000)
        libpthread.so.0 => /lib/tls/libpthread.so.0 (0x00747000)
        libdl.so.2 => /lib/libdl.so.2 (0x00876000)
        libc.so.6 => /lib/tls/libc.so.6 (0x00111000)
        /lib/ld-linux.so.2 (0x00f55000)
[root@design.bg httpd-2.0.53]#

Yes it's true that i have a libiconv on the machine but i don't see any option i
have to configure it to use the libiconv library. Here is my configure.nice file
i use for the compilation.

[root@design.bg httpd-2.0.53]# cat httpd-config.nice
#! /bin/sh
#
# Created by configure

"./configure" \
"--disable-autoindex" \
"--disable-negotiation" \
"--disable-userdir" \
"--with-mpm=worker" \
"--disable-ssl" \
"--enable-include" \
"--enable-auth" \
"--enable-auth-digest" \
"--enable-vhost-alias" \
"--enable-access" \
"--enable-asis" \
"--enable-imap" \
"--enable-actions" \
"--disable-autoindex" \
"--enable-env" \
"--enable-setenvif" \
"--enable-mime" \
"--disable-charset-lite" \
"--enable-auth-digest" \
"--enable-log-config" \
"--enable-deflate" \
"--enable-http" \
"--enable-rewrite" \
"--enable-so" \
"--enable-dir" \
"--enable-nonportable-atomics=yes" \
"--sysconfdir=/usr/local/apache2/conf" \
"--sbindir=/usr/local/apache2/sbin" \
"--bindir=/usr/local/apache2/bin" \
"--enable-status" \
"$@"
[root@design.bg httpd-2.0.53]#
I think this is a bug in the new configure system that comes with apache 2.0.53
the same config.ini file works perfectly for me on a previous 2.0.52 version.
Really sorry if the mistake is mine and i'm loosing of your time.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message