httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 33425] New: - mod_dir behavior with mod_proxy and DirectoryIndex
Date Mon, 07 Feb 2005 15:36:11 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=33425>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=33425

           Summary: mod_dir behavior with mod_proxy and DirectoryIndex
           Product: Apache httpd-2.0
           Version: 2.0.52
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_dir
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: rgranvin@iglide.net


I -know- that this is technically a repeat of bug #15112, however I am 
experiencing the same problems that is documented as being applied to 2.0.51.

Scenario:

DirectoryIndex contains several files, e.g. "index.html, index.htm, index.cfm".

Our web server is on a physically different machine from our ColdFusion 
server.  Therefore, any "*.cfm" file must be proxied to the alternate server.  
Although this is not a good example of code :-), this is just to illustrate 
the process:

     ProxyRequests Off
     ProxyVia On
     <Proxy *>
             Order deny,allow
             Allow from all
     </Proxy>
     ReWriteEngine on
     RewriteRule (.*)\.cfm$ /cfm/$1.cfm [P]
     ProxyPass /cfm http://appserver.exampledomain.org 
     ProxyPassReverse /cfm http://appserver.exampledomain.org 

This configuration works just fine as long as the URL is complete.  
i.e., "/directory/index.cfm".

However, if mod_dir must extract a match from DirectoryIndex (e.g., a URL 
of "/directory" or "/directory/" where the match in the directory is 
index.cfm, the proxy is not applied and Apache attempts to 
load "/directory/index.cfm" from the local server instead.

In the above referenced closed bug, this apparently was to be fixed by 
restoring mod_dir to its original behavior.  However, we are still 
encountering the same issue with 2.0.52.

I have raised this question on the user list and another list without a 
successful response, so as much as I really didn't want to, drafting a bug on 
it in hopes that there is a resolution to this.  This one is unfortunately a 
show-stopper for us (without explicitly rewriting a lot of hardcoded URLS).

Appreciate any insight...

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message