httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 32730] - Error 500 on Non-UTF-8 Encoded PATH_INFO on Windows
Date Sun, 09 Jan 2005 08:41:44 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=32730>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=32730





------- Additional Comments From rd9@donkin.org  2005-01-09 09:41 -------
I tried the new libhttpd.dll under my Apache setup and I got a somewhat
different conversion error:

(22)I(22)Invalid argument: utf8 to ucs2 conversion failed on this string:
PATH_TRANSLATED=C:\\apachefriends\\xampp\\htdocs\\Main\\FromageD\xe9rap\xe9

This is happening later in the process as you can see, on the file not the URL
as in the original bug.   The URL used was
http://localhost:8080/cgi-bin/view/Main/FromageD%E9rap%E9 as in the bug report.

I know this is not a server or application config issue because
http://localhost:8080/cgi-bin/view/Main/WebHome works fine even though
C:\\apachefriends\\xampp\\htdocs\\Main\\WebHome does not exist as a file either.
 So it seems there is a file-existence check somewhere that is also requiring a
translation of PATH_INFO even though the file doesn't have to exist. 

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message