httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 23421] - Remove AddDefaultCharset from httpd.conf as shipped
Date Thu, 09 Dec 2004 14:16:40 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=23421>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=23421





------- Additional Comments From sebastiaan@kantoor.nederhost.nl  2004-12-09 15:16 -------
In addition to the principal reasons given earlier there is also a pragmatic
reason not to use AddDefaultCharset in the default httpd.conf. Sending the
charset declaration triggers an obscure bug in MSIE with multipart forms, as
documented at
http://www.interactivetools.com/forum/gforum.cgi?post=34345;sb=post_latest_reply;so=ASC;forum_view=forum_view_collapsed
(at the bottom).

I know that Microsoft should fix their browser but I spend a lot of time today
debugging an old script that didn't work after upgrading to Apache 2 because of
this. I think the right thing is not to trigger bugs in a product that is still
used by so many users by shipping a httpd.conf that contains this as a default.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message