httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 29744] - connect method don't work on ssl sockets
Date Wed, 10 Nov 2004 23:37:27 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=29744>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=29744

connect method don't work on ssl sockets

brad_boyer@symantec.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |brad_boyer@symantec.com
           Keywords|                            |PatchAvailable



------- Additional Comments From brad_boyer@symantec.com  2004-11-10 23:37 -------
The patch I just attached converts proxy_connect.c to use the bb/filter routines
to do I/O instead of directly using apr_send/apr_recv on the sockets. I've
tested it both with a normal web browser using it for SSL proxying (uses normal
HTTP), and with a custom written client that uses HTTPS to talk to the proxy. It
works for me. It's against 2.0.52, but it doesn't look like that stuff has
changed any time recently.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message