httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 27550] - pcre symbol issues for apache modules
Date Thu, 30 Sep 2004 17:52:30 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=27550>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=27550

pcre symbol issues for apache modules

apache-bugs.20.openmacnews@spamgourmet.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Severity|Normal                      |Major
         OS/Version|Linux                       |All
           Priority|Other                       |Medium
           Platform|Other                       |All
            Version|2.0.50                      |2.0-HEAD



------- Additional Comments From apache-bugs.20.openmacnews@spamgourmet.com  2004-09-30 17:52
-------
hi,

i'm back again!

i'm building httpd 2.0.52 + php 5.0.2 on OSX 10.3.5

the ONLY way i'm able to get httpd & php to 'play nice' together -- avoiding later/'downstream'
pcre 
conflicts -- is to make sure that they're built using the SAME version of pcre.

there are two options to that end ...

(a)
        build httpd w/ INTERNAL pcre (v3.9)
        build external pcre3.9
        build php 502 against pcre3.9/external

(b)
        apply Andreas' patch to httpd (*luckily* the patch still works against 2.0.52 ...)
        build external pcre5.0
        build httpd 2.0.52 against pcre5.0/external
        build php 5.0.2 against pcre5.0/external

(a), of course, locks PHP into the use of pcre3.9 ... which is simply not acceptable/tenable
for a variety 
of other apps that need >= v4.5

so, (b) is really the only functional option here ...

acknowledging 'possible subleties' from  Joe's reference above, the php issue is neither subtle,
nor 
simply possible ... others as well (cref above) are noting problems with, e.g., mod_caml that
requires a 
more recent pcre.

what need to be done to get this solution addressed/integrated?  even ASSIGNED would be a
good start!

this has been an unaddressed issue problem for QUITE awhile ...

richard

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message