httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 31302] - suexec doesn't execute commands if they're not in the current dir
Date Mon, 20 Sep 2004 00:23:19 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=31302>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=31302

suexec doesn't execute commands if they're not in the current dir





------- Additional Comments From divisor@ad69.com  2004-09-20 00:23 -------
In 1.3.x suexec executes programs in subdirs well if there's a correct relative
path in the ssi command.

I noticed that apache 2.0.51 gives to suexec just a program name, without a
path, i.e. example.cgi instead of ./somedir/example.cgi when 1.3.x gives to
suexec a program name together with a path.

Maybe this is a feature of 2.0.x :) but many sites have such includes and can't
be transferred to 2.0.x if the system is configured to work with suexec.

If the problem executing programs in subdirs via ssi+suexec isn't going to be
solved in 2.0.x could you plz advice how to configure or manually patch apache
2.0.x to transfer such sites? I would be greatly appreciated. Thanks you.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message