httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 30487] - Apache 2.0.50 refuses to serve pages when compiled with AIX 'xlc' ort 'xlc_r' compiler
Date Wed, 08 Sep 2004 14:58:34 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=30487>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=30487

Apache 2.0.50 refuses to serve pages when compiled with AIX 'xlc' ort 'xlc_r' compiler

trawick@apache.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|REOPENED                    |RESOLVED
         Resolution|                            |FIXED



------- Additional Comments From trawick@apache.org  2004-09-08 14:58 -------
okay, I can verify that with xlc 5.0.2.5 I don't need the patch if I use CC=cc_r
CFLAGS=-O2 but I do need the patch if I use CC=xlc_r CFLAGS=-O2

the difference in xlc_r and cc_r behavior can be seen in /etc/vac.cfg, which
specifies what libraries and other options are used based on the wrapper (CC)

the difference is in the default options
  cc_r has -qlanglvl=extended,-qnoro,-qnoroconst
 xlc_r has -qansialias

all other options, libraries, stubs, and library paths are the same

I've updated README.platforms to point out
  stable location of the server/core.c patch
  xlc_r -O2 needs the patch
  cc_r  -O2 doesn't need the patch

Thanks for your research on this topic!

(I'll update my unofficial notes on AIX + Apache2 shortly.)

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message