httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 31053] New: - libapreq2-2.04-dev: "apreq_parsers.c", line 121: error 1521: Incorrect initialization on HP-UX 64bit with ansi C (not gcc) compiler.
Date Fri, 03 Sep 2004 18:05:13 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=31053>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=31053

libapreq2-2.04-dev: "apreq_parsers.c", line 121: error 1521: Incorrect initialization on HP-UX
64bit with ansi C (not gcc) compiler.

           Summary: libapreq2-2.04-dev: "apreq_parsers.c", line 121: error
                    1521: Incorrect initialization on HP-UX 64bit with ansi
                    C (not gcc) compiler.
           Product: Apache httpd-2.0
           Version: 2.0-HEAD
          Platform: HP
        OS/Version: HP-UX
            Status: NEW
          Severity: Blocker
          Priority: Other
         Component: All
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: krichine@juno.com


Hi!
 
This bug is actually for libapreq2.
both Apache2 and mod_perl2 built and work fine, however, I can't build 
Apache::Request (see below).
Sorry if this is incorrect Product/Component, but I was not able to locate 
libapreq2 in the list.

I am trying to make Apache::Request (libapreq2-2.04-dev) and getting the 
following:
 
/opt/libapreq2-2.04-dev > make
No suffix list.
Making all in src
        /bin/sh ../libtool --mode=compile cc -DHAVE_CONFIG_H -I. -I. -I. -
I/opt/apache2/include   -I/opt/apache2/include   -Aa -D__STDC_EXT__ -
D_HPUX_SOURCE -Ae -D_HPUX_SOURCE -Wl,+vnocompatwarnings +DD64  +DA2.0W  -
DHPUX11 -D_REENTRANT -D_XOPEN_SOURCE_EXTENDED  -Ae -D_HPUX_SOURCE -
Wl,+vnocompatwarnings +DD64 +DA2.0W -D_LARGEFILE_SOURCE -
D_FILE_OFFSET_BITS=64  -c apreq_parsers.c
 cc -DHAVE_CONFIG_H -I. -I. -I. -I/opt/apache2/include -I/opt/apache2/include -
Aa -D__STDC_EXT__ -D_HPUX_SOURCE -Ae -D_HPUX_SOURCE -Wl,+vnocompatwarnings 
+DD64 +DA2.0W -DHPUX11 -D_REENTRANT -D_XOPEN_SOURCE_EXTENDED -Ae -
D_HPUX_SOURCE -Wl,+vnocompatwarnings +DD64 +DA2.0W -D_LARGEFILE_SOURCE -
D_FILE_OFFSET_BITS=64 -c apreq_parsers.c  +Z -DPIC -o .libs/apreq_parsers.o
cc: "apreq_parsers.c", line 121: error 1521: Incorrect initialization.
cc: "apreq_parsers.c", line 122: error 1521: Incorrect initialization.
*** Error exit code 1
Stop.
*** Error exit code 1
Stop.

 
Here is what my system is (HP-UX 64-bit everything):

HP-UX B.11.00 A 9000/800 281894381 two-user license
perl -V
Summary of my perl5 (revision 5.0 version 8 subversion 3)
configuration:
  Platform:
    osname=hpux, osvers=11.00, archname=PA-RISC2.0-LP64
    uname='hp-ux firehawk b.11.00 a 9000800 281894381 two-user license
'
    config_args='-de -Dprefix=/opt/perl -Duse64bitall -A
prepend:libswanted=cl pthread '
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=undef use5005threads=undef useithreads=undef
usemultiplicity=undef
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=define use64bitall=define uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags =' -Ae -D_HPUX_SOURCE -Wl,+vnocompatwarnings
+DD64 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 ',
    optimize='+O2 +Onolimit',
    cppflags='-Aa -D__STDC_EXT__ -D_HPUX_SOURCE -Ae -D_HPUX_SOURCE
-Wl,+vnocompatwarnings +DD64'
    ccversion='A.11.01.25171.GP', gccversion='', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=87654321
    d_longlong=define, longlongsize=8, d_longdbl=define,
longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t',
lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='/usr/bin/ld', ldflags =' +DD64 -L/usr/local/lib
-L/lib/pa20_64'
    libpth=/usr/local/lib /lib/pa20_64 /lib /usr/lib /usr/ccs/lib
    libs=-lcl -lpthread -lnsl -ldl -ldld -lm -lsec -lc
    perllibs=-lcl -lpthread -lnsl -ldl -ldld -lm -lsec -lc
    libc=/lib/pa20_64/libc.sl, so=sl, useshrplib=false,
libperl=libperl.a
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_hpux.xs, dlext=sl, d_dlsymun=undef, ccdlflags='-Wl,-E
-Wl,-B,deferred '
    cccdlflags='+Z', lddlflags='-b +vnocompatwarnings -L/usr/local/lib
-L/lib/pa20_64'


Characteristics of this binary (from libperl):
  Compile-time options: USE_64_BIT_INT USE_64_BIT_ALL USE_LARGE_FILES
  Built under hpux
  Compiled at Apr  5 2004 14:24:13
  @INC:
    /opt/perl/lib/5.8.3/PA-RISC2.0-LP64
    /opt/perl/lib/5.8.3
    /opt/perl/lib/site_perl/5.8.3/PA-RISC2.0-LP64
    /opt/perl/lib/site_perl/5.8.3
    /opt/perl/lib/site_perl
    .

Apache2 (I only have Apache2, no 1, nothing to be compatible with):
export LDFLAGS=' -lcl -lpthread -L/usr/local/lib -L/lib/pa20_64 '
export CPPFLAGS=' -Aa -D__STDC_EXT__ -D_HPUX_SOURCE -Ae -D_HPUX_SOURCE
-Wl,+vnocompatwarnings +DD64  +DA2.0W '
export CFLAGS=' -Ae -D_HPUX_SOURCE -Wl,+vnocompatwarnings +DD64
+DA2.0W -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 '
#./configure --prefix=/opt/apache2 --with-mpm=prefork --with-port=77
--with-perl=/opt/perl/bin/perl

Server version: Apache/2.0.50
Server built:   Aug 13 2004 12:57:17
(this was built also with 64-bit) using all the proper flags:
export LDFLAGS=' -lcl -lpthread -L/usr/local/lib -L/lib/pa20_64 '
export CPPFLAGS=' -Aa -D__STDC_EXT__ -D_HPUX_SOURCE -Ae -D_HPUX_SOURCE
-Wl,+vnocompatwarnings +DD64  +DA2.0W '
export CFLAGS=' -Ae -D_HPUX_SOURCE -Wl,+vnocompatwarnings +DD64
+DA2.0W -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 '

 
I also have successfully built mod_perl-1.99_16 and was able to load it fine.

Thanks.
Kirill

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message