httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 30919] New: - mod_info failed to show all info
Date Sat, 28 Aug 2004 22:02:18 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=30919>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=30919

mod_info failed to show all info

           Summary: mod_info failed to show all info
           Product: Apache httpd-2.0
           Version: 2.1-HEAD
          Platform: All
               URL: http://rici.ricilake.net/src/mod_info.c
        OS/Version: All
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: mod_info
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: ricilake@speedy.com.pe


In the scan of sub-config trees, mod_info sometimes seems to lose track of where it was, failing
to 
provide all information and/or scrambling the </close> tags. This seems particularly
evident in 
<VirtualHost> sections.

The easiest way to fix it seemed to be to rewrite the tree scan recursively; the enclosed
patch 
implements that, as well as correctly indenting subsection headers and allowing for indentation
nesting  
of more than two levels.

It also implements a new feature: ?config simply dumps the entire configuration tree without
sorting it 
into modules. I left the indentation incorrect in the second part in order to avoid adding
130 specious 
lines to the patch.

The file in the url is the complete mod_info.c, detabbed and indented properly

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message