httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 30610] New: - RewriteRule does not recognize escaped ? in regular expression (i.e. \?
Date Thu, 12 Aug 2004 00:57:01 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=30610>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=30610

RewriteRule does not recognize escaped ? in regular expression (i.e. \?

           Summary: RewriteRule does not recognize escaped ? in regular
                    expression (i.e. \?
           Product: Apache httpd-2.0
           Version: 2.0-HEAD
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: mod_rewrite
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: calmman@hotmail.com


I have the following configuration:

RewriteEngine On
RewriteRule ^(.*)Link\?(.*) /link.php?dir=$1&$2

I expect a request /bd/Link?a=b to be translated to /link.php?dir=/bd/&a=b 
but rewrite rule newer gets executed.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message