httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 29985] - poll depreciated in OS X 10.3 and incorrectly detected by configure script
Date Sat, 10 Jul 2004 23:19:24 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=29985>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=29985

poll depreciated in OS X 10.3 and incorrectly detected by configure script





------- Additional Comments From chip@force-elite.com  2004-07-10 23:19 -------
Best that I can figure out is that poll.h was removed from 10.3.  Therefore,
people who upgraded from 10.2 -> 10.3 will still have the header, but any fresh
installs will not.

It sounds like the function itself is still in their libc/kernel, but its public
header is gone.  As a side note, Darwin and OSX support KQueue, so in the future
we should be able to use these methods for higher performance instead of select().

To resolve this bug, I guess we need some more autoconf foo to disable poll() if
it is not in any public headers?

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message