httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 29991] New: - <VirtualHost _default_:80> bug
Date Fri, 09 Jul 2004 06:22:52 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=29991>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=29991

<VirtualHost _default_:80> bug

           Summary: <VirtualHost _default_:80> bug
           Product: Apache httpd-2.0
           Version: 2.0.49
          Platform: PC
        OS/Version: FreeBSD
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: All
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: ilia@paramon.ru


I have the following setup:

NameVirtualHost *:80

<VirtualHost *:80>
ServerName www.amolini.tv
ServerAlias amolini.tv
</VirtualHost>

<VirtualHost *:80>
ServerName www.aloepole.ru
ServerAlias aloepole.ru
</VirtualHost>

<VirtualHost _default_:80>
#no ServerName here
</VirtualHost>

I expected to see sites www.amolini.tv, amolini.tv, www.aloepole.ru, 
aloepole.ru as usual, and other requests default to "_default_"

but instead of that I see sites www.aloepole.ru, aloepole.ru, amolini.tv
and www.amolini.tv goes to "_default_" section

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message