httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 29944] New: - LDAP shared memory cache is not using SHM for cache entries
Date Wed, 07 Jul 2004 09:21:26 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=29944>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=29944

LDAP shared memory cache is not using SHM for cache entries

           Summary: LDAP shared memory cache is not using SHM for cache
                    entries
           Product: Apache httpd-2.0
           Version: 2.0.49
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Major
          Priority: Other
         Component: mod_ldap
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: jah@progress.com


Apache 2.0.49 (and 2.0.50-dev) util_ldap shared memory cache is not using shared
memory for cache entries. This is caused by util_ald_create_cache() function not
initializing the cache->rmm_addr at all. I will attach a patch that fixes this
problem.

Another issue is the cache creation logic in util_ald_create_cache().

If the build doesn't use shared memory (APR_HAS_SHARED_MEMORY is not defined),
the cache will be created as long as st->search_cache_size > 0.

If APR_HAS_SHARED_MEMORY is defined, the cache will only be created if we have
shared memory allocated (st->cache_rmm is not NULL).

If st->cache_rmm is NULL, shouldn't the cache be created in process memory (with
calloc) instead of not creating it at all ? This behavior would be consistent
with documentation.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message