httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 29927] - apache 2.0.50 + suexec doesn't work - APR not reporting SETUID bits properly
Date Tue, 06 Jul 2004 05:49:29 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=29927>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=29927

apache 2.0.50 + suexec doesn't work - APR not reporting SETUID bits properly





------- Additional Comments From dave@cs.curtin.edu.au  2004-07-06 05:49 -------
ok:

here is my configure line:

./configure --prefix=/usr/httpd --enable-ssl --enable-http --enable-cgi --
disable-userdir --enable-suexec --with-suexec-caller=nobody

[root@ns]# ls -las /usr/httpd/bin/suexec
44 -rwsr-xr-x  1 root root 44040 Jul  6 15:38 /usr/httpd/bin/suexec

im running fedora core 1 with all the yum updates

the line that seems to be the problem is line 601 in os/unix/unixd.c:

if ((apr_stat(&wrapper, SUEXEC_BIN, APR_FINFO_NORM, ptemp)) != APR_SUCCESS) {

when i check wrapper.protection it is equal to 1877 or 1855 i cant remember now.

the next if statement (wrapper.protection & APR_USETID) comes to == 0 - so 
effectively it leaves unixd_config.suexec_enabled set to 0 - and i get the 
warning.

cheers
dave

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message