httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 29660] New: - Problem with cygwin+apache 1.3.31+mod_perl-1.29
Date Fri, 18 Jun 2004 08:10:56 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=29660>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=29660

Problem with cygwin+apache 1.3.31+mod_perl-1.29

           Summary: Problem with cygwin+apache 1.3.31+mod_perl-1.29
           Product: Apache httpd-1.3
           Version: HEAD
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: core
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: pkc@F1-Photo.com


Clean cygwin install
Unpacked 1.3.31 and mod_perl 1.29
Ran perl Makefile.PL
Built everything without any problem
Ran make install, no problem
Had to copy httpd.exe manually since it's not working properly(
http://issues.apache.org/bugzilla/show_bug.cgi?id=29586 )

Tried running httpd:

/usr/local/apache/bin$ /usr/local/apache/bin/apachectl start
/usr/local/apache/bin/apachectl start: httpd could not be started

Error log is empty: 
/usr/local/apache/logs$ ls -al *log
-rw-r--r--    1 Admin None            0 Jun 18 09:50 error_log

Using GDB i get:
Starting program: /usr/local/apache/bin/httpd.exe 

Program received signal SIGSEGV, Segmentation fault.
0x77e4af90 in KERNEL32!IsBadWritePtr () from
/cygdrive/c/WINDOWS/system32/kernel32.dll
(gdb) bt
#0  0x77e4af90 in KERNEL32!IsBadWritePtr () from
/cygdrive/c/WINDOWS/system32/kernel32.dll
#1  0x00000013 in ?? ()
#2  0x0022ea54 in ?? ()
#3  0x00000012 in ?? ()
#4  0x0022e000 in ?? ()
#5  0x0022e000 in ?? ()
#6  0x0022d40c in ?? ()
#7  0x77f8c494 in ntdll!RtlUpperChar () from ntdll.dll
#8  0x0022f090 in ?? ()
#9  0x77e70abc in ValidateLocale () from /cygdrive/c/WINDOWS/system32/kernel32.dll
#10 0x610a92ed in cygwin1!__getreent () from /usr/bin/cygwin1.dll
#11 0x00000008 in ?? ()
#12 0x0022d468 in ?? ()
#13 0x610a9387 in cygwin1!__getreent () from /usr/bin/cygwin1.dll
#14 0x00000868 in ?? ()
#15 0x00000868 in ?? ()
#16 0x0022ea54 in ?? ()


Could be a cygwin bug, could be an apache one, i'm unable to confirm

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message