httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 28531] - httpd-2.1.0-pre3 ldap authentification error
Date Fri, 21 May 2004 08:11:31 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=28531>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=28531

httpd-2.1.0-pre3 ldap authentification error





------- Additional Comments From erwin.leubaz@advancedsilicon.com  2004-05-21 08:11 -------
Correct, I have enabled mod_authn_file.

But if I remove it, the error become :

configuration error:  couldn't perform authentication. AuthType not set!: /ldap-
status

And if I change the configuration like this :

<Location /ldap-status>

SetHandler ldap-status
Order deny,allow
Deny from all
AuthType Basic
AuthName "Test Ldap"
Allow from yourdomain.example.com #modified with correct value on 2.0.48
AuthLDAPEnabled on
AuthLDAPURL ldap://127.0.0.1/dc=example,dc=com?uid?one #modified with correct 
value on 2.0.48
AuthLDAPAuthoritative on
require valid-user

</Location>

I receive :

No Authn provider configured

Is this always a mistake in the configuration ?
Or could you give me a example with the minimum modules to load and a 
<Location> 
example
</Location>

That I reproduce a correct environement.

Thanks in advance.

Regards

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message