httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 28854] New: - Build fails with missing library call on Solaris if GNU iconv is installed
Date Sun, 09 May 2004 05:59:02 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=28854>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=28854

Build fails with missing library call on Solaris if GNU iconv is installed

           Summary: Build fails with missing library call on Solaris if GNU
                    iconv is installed
           Product: Apache httpd-2.0
           Version: 2.0.49
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Build
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: schatt@schatt.com


On Solaris 2.9 (probably earlier) if the GNU iconv package is installed, the apr-util configuration

properly detects whether or not libiconv is installed, but fails to test to see whether or
not the -liconv 
option needs to be added to the LIBS or EXTRA_LIBS variables (it does - since the functions
are NOT 
present in the system libraries.
I think that the best way to solve this would be to include a test in the apr-util/configure
script that, if 
iconv.h is detected, then tests to see if -liconv is necessary to use its functions.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message