httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 28198] New: - POSTed data is not send to handler when use "Action" and "AddHandler"
Date Mon, 05 Apr 2004 08:12:15 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=28198>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=28198

POSTed data is not send to handler when use "Action" and "AddHandler"

           Summary: POSTed data is not send to handler when use "Action" and
                    "AddHandler"
           Product: Apache httpd-1.3
           Version: HEAD
          Platform: Other
        OS/Version: Other
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: core
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: masaru@turbolinux.co.jp


POSTed data is not send to handler when use "Action" and "AddHandler". When I
add use the CGIWrap as handler of CGI, and regist it with "Action" and
"AddHandler" statement.

I wrote following into httpd.conf

   AddHandler cgi-wrapper .cgi
   ScriptAlias /.cgiwrapDir/ /usr/lib/cgiwrap/
   Action cgi-wrapper /.cgiwrapDir/cgiwrap

And I wrote a CGI program it recieve data sent by POST method. The environment
variable CONTENT_LENGTH was set correctory, but the CGI program cannot read any
of data from its stdin.

I traced mod_actions.c and mod_cgi.c. I found the variable r->read_length is not
zero when above condition.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message