httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 28144] New: - mozilla seems to stumble on a https 1.1 site with multiple redirects
Date Thu, 01 Apr 2004 23:21:29 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=28144>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=28144

mozilla seems to stumble on a https 1.1 site with multiple redirects

           Summary: mozilla seems to stumble on a https 1.1 site with
                    multiple redirects
           Product: Apache httpd-2.0
           Version: 2.0.49
          Platform: Other
               URL: http://gamma.fortn.net/basen
        OS/Version: Linux
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: mod_proxy
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: kajtzu@basen.net


Note: I'm filing this against httpd 2.0.49 as the Mozilla guys stated in
<http://bugzilla.mozilla.org/show_bug.cgi?id=239392#c8> that it doesn't look
like a problem with the browser itself. :)

Assume the topology looks like Browser <= HTTPS => Frontends <= HTTP => Backends
Assume the Frontends run a reverse proxy configuration with mod_proxy using
Apache 2.0.49 to a bunch of Tomcat 4.1.29 or Jetty 4.x servlet containers. The
_HTTPS_ connection terminates on the Apaches and mod_proxy opens a new _HTTP_
connection to the backends.

Assume the Apaches are at their default settings.

Assume user is using either Mozilla 1.6 (Linux or Win32) or Firebird 0.8 (Linux
or Win32).

Assume the user enters the URL as "https://gamma.fortn.net/basen" without the
double quotes.

Works, Apache returning HTTP 1.1 responses <http://gamma.fortn.net/basen>
(no special configuration)

Works, Apache returning HTTPS 1.0 responses <https://gamma.fortn.net/basen>
(Special config "SetEnvIf User-Agent ".*Mozilla/5.0.*" downgrade-1.0")

Fails, Apache at its default settings using HTTPS 1.1 and keepalives
<https://gamma.fortn.net/basen1>


Reproducible: Always

Actual Results:  
A printout of the redirects with the reload button grayed out. CTRL-R will
reload the correct page, though.

Expected Results:  
Don't choke on the redirect.

I'll attach a picture of what it looks like and header dumps. The URLs are real
so you're welcome to try to reproduce if you feel like it. :-)

All three examples work with IE 5.5 (Win32), IE 6.x (Win32), lynx (multiple
platforms), links (multiple platforms), wget (multiple platforms) and Safari (OS X).

I did try with "SetEnvIf User-Agent ".*Mozilla/5.0.*" nokeepalive" but that made
no difference.

The attachments are over at mozilla's bugzilla but I can attach them here too if
that's needed.

Thanks.. Any ideas?

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message