httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 27378] New: - open_logs hook called before post_config hook
Date Tue, 02 Mar 2004 19:12:10 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=27378>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=27378

open_logs hook called before post_config hook

           Summary: open_logs hook called before post_config hook
           Product: Apache httpd-2.0
           Version: 2.0.48
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Core
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: eddie@omegaware.com


Why is the open_logs hook run before the post_config hook?

I am working on the mod_log_sql module (new maintainer), and have some code in
the post_config hook to assign global defaults ( i have a global per module
config structure as well as per server configuration) if they have not been set
by a configuration directive that need to be setup BEFORE the initial connection
to the database called in open_logs.  However after placing many APLOG_DEBUG and
step by step gdb debugging, I find that post_config is called after open_logs..
I'm thinking that this is a bug as it makes much more sense to call post_config
before open_logs.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message