httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 24595] New: - LDAP authenication starts failing right after a wrong credentials has been used
Date Tue, 11 Nov 2003 01:59:10 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=24595>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=24595

LDAP authenication starts failing right after a wrong credentials  has been used

           Summary: LDAP authenication starts failing right after a wrong
                    credentials  has been used
           Product: Apache httpd-2.0
           Version: 2.0.47
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: mod_auth_ldap
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: nnath@westlakefinancial.com


Hi,

I had noticed this months ago and just ignored it , opting to work with 1.3 
instead. Anyways the syptom is that LDAP authentication using mod_auth_ldap 
works for a while and suddenly fails.

Upon investigation , I found that the Authetication works untill a wrong 
credential has been passed. After that trying to login with proper 
login/password just does not work for anybody.

The only way to fix this is to restart apache.

Server Identification string:
Apache/2.0.47 (Win32) Server at purchaseorder.westlakefinancial.com Port 80

The error log below:

[Mon Nov 10 17:42:17 2003] [warn] [client 10.1.11.172] [4476] auth_ldap 
authenticate: user nnath authentication failed; URI /cgi-bin/htmlos.exe 
[ldap_simple_bind_s() to check user credentials failed][Invalid Credentials]
[Mon Nov 10 17:42:21 2003] [warn] [client 10.1.11.172] [4476] auth_ldap 
authenticate: user nnath authentication failed; URI /cgi-bin/htmlos.exe [User 
not found][No Such Object]
[Mon Nov 10 17:42:24 2003] [warn] [client 10.1.11.172] [4476] auth_ldap 
authenticate: user nnath authentication failed; URI /cgi-bin/htmlos.exe [User 
not found][No Such Object]
[Mon Nov 10 17:49:33 2003] [warn] [client 10.1.11.172] [4476] auth_ldap 
authenticate: user nnath authentication failed; URI /cgi-bin/htmlos.exe [User 
not found][No Such Object]
[Mon Nov 10 17:49:34 2003] [warn] [client 10.1.11.172] [4476] auth_ldap 
authenticate: user nnath authentication failed; URI /cgi-bin/htmlos.exe [User 
not found][No Such Object]
[Mon Nov 10 17:49:35 2003] [warn] [client 10.1.11.172] [4476] auth_ldap 
authenticate: user  authentication failed; URI /cgi-bin/htmlos.exe 
[ldap_search_ext_s() for user failed][Filter Error]

Thanks
Nikh Nath

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message