httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 24152] New: - Apache is restarting instead of reloading
Date Mon, 27 Oct 2003 15:48:37 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=24152>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=24152

Apache is restarting instead of reloading

           Summary: Apache is restarting instead of reloading
           Product: Apache httpd-1.3
           Version: 1.3.28
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Other mods
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: mc@webheberg.com


Hello,

I'm using Apache with mod_ssl dynamically loaded 

I start Apache with these lines :
start() { 
        echo -n $"Starting $prog: "
        daemon $httpd -DSSL `moduleargs` $OPTIONS
        RETVAL=$?
        echo
        [ $RETVAL = 0 ] && touch /var/lock/subsys/httpd
        return $RETVAL
}

And I reload it with :
reload)
        echo -n $"Reloading $prog: "
        killproc $httpd -HUP
        RETVAL=$?
        echo
        ;;

My problem is the following : when I reload Apache, in fact, I restart it. I 
see it on the server-status page : all the processes are killed, and the uptime 
is set back to 0. It also makes all the current downloads fail, as a restart 
closes all the active connections. 

Is there any patch to apply, so that Apache+mod_ssl won't restart when I just 
reload it ?

Thanks for your help

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message