httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 19000] - (ERR_LIB_PEM) Unable to compile mod_ssl error in SSL_CTX_use_certificate_chain
Date Sat, 13 Sep 2003 23:46:32 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=19000>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=19000

(ERR_LIB_PEM) Unable to compile mod_ssl error in SSL_CTX_use_certificate_chain





------- Additional Comments From gigil@room666.biz  2003-09-13 23:46 -------
same thing happens with OpenSSL 0.9.7b , apache 2.0.47 on a freebsd 4.8 server..
I figure out that in modules/ssl/mod_ssl.h the second include err.h should to be
changed:

--- modules/ssl/mod_ssl.h.orig  Sat Sep 13 19:36:51 2003
+++ modules/ssl/mod_ssl.h       Sat Sep 13 19:15:43 2003
@@ -123,7 +123,7 @@
 #else /* !HAVE_SSLC (implicit HAVE_OPENSSL) */

 #include <ssl.h>
-#include <err.h>
+#include <openssl/err.h>
 #include <x509.h>
 #include <pem.h>
 #include <crypto.h>

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message