httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 21253] New: - Mime magic doesn't continue if type is specifed for the first match
Date Tue, 01 Jul 2003 23:46:43 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21253>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21253

Mime magic doesn't continue if type is specifed for the first match

           Summary: Mime magic doesn't continue if type is specifed for the
                    first match
           Product: Apache httpd-2.0
           Version: 2.0.40
          Platform: Other
        OS/Version: Linux
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: mod_mime_magic
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: apang@mdsi.ca


The WAVE "magic" probably doesn't work:

0       string          RIFF            audio/unknown
>8      string          WAVE            audio/x-wav

I used it as a reference to see if I could send application/xhtml+xml for (my)
XHTML documents, and text/xml as the default for other XML documents.

Using:

0   string      \<?xml      text/xml
>44 string      \<!DOCTYPE\ HTML    application/xhtml+xml

The content type for an XHTML document, rather unexpectedly, returned:
"text/xml" followed by some trailing garbage text.

Note: this is a low priority (for me) as I've since discovered that IE6 does not
recognize "application/xhtml+xml" (as mentioned in 5.1 of the XHTML 1.0 spec.).

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message