httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 20402] New: - Bug in CGI environment variable
Date Mon, 02 Jun 2003 05:29:28 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=20402>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=20402

Bug in CGI environment variable

           Summary: Bug in CGI environment variable
           Product: Apache httpd-2.0
           Version: 2.0.40
          Platform: PC
               URL: http://tombo.miniasp.com/cgi-
                    bin/b2g_bug.cgi/http://www.ep66.idv.tw
        OS/Version: Other
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: mod_cgi
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: doggy_epaper@one4ok.com
                CC: doggy_epaper@one4ok.com


For this url above:
http://tombo.miniasp.com/cgi-bin/b2g_bug.cgi/http://www.ep66.idv.tw

The SCRIPT_NAME variable should be /cgi-bin/b2g_bug.cgi , but the mod_cgi send 
me "/cgi-bin/b2g_bug.cgi/http:".

The PATH_INFO variable also wrong.

The PATH_INFO should be "/http://www.ep66.idv.tw" , but the mod_cgi send 
me "/http:/www.ep66.idv.tw".  It strip away one slash(/).

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message