httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 19711] - SetEnvIf and SetEnvIf do not work under Windows 2000
Date Fri, 09 May 2003 23:44:15 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=19711>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=19711

SetEnvIf and SetEnvIf do not work under Windows 2000





------- Additional Comments From nd@perlig.de  2003-05-09 23:44 -------
Hmm. That is really strange. It works for me like a charm and I cannot find any
odds. But I cannot test SSLProxy at the moment. Can you confirm that it doesn't
work without SSL enabled?

My config (extracted from yours, just exchanged some values)

SetEnvIf Remote_Addr "192\.168\.0\.1" mylogvar
CustomLog logs/mylog.log common env=mylogvar

and

ProxyRequests On
#
<Proxy *>
    Order deny,allow
	Deny from all
    Allow from 0.0.0.0/0.0.0.0
</Proxy>

ProxyPass /foo http://otherhost
ProxyPassReverse /foo http://otherhost

(By the way, if you want to deny all proxy requests, just turn ProxyRequests Off
and remove the <Proxy> container.)

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message