httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 18730] - apache 2.0.45 seg faults when SSL is enabled.
Date Mon, 21 Apr 2003 10:48:21 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18730>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18730

apache 2.0.45 seg faults when SSL is enabled.





------- Additional Comments From trawick@apache.org  2003-04-21 10:48 -------
Can you check your SSLMutex directive for a valid path to the mutex?

Apparently something changed with 2.0.45 that led to a previously-ignored path
on the SSLMutex directive being used, and people with a bad path all along
started segfaulting.
The bug has been fixed in APR, but you'd need to fix the path on the directive
anyway.

If it isn't a problem with a bad path on the SSLMutex directive, please submit
a backtrace from the segfault.

One way to get a backtrace is like this:

gdb /path/to/httpd
(gdb) r -DONE_PROCESS -DSSL

(it runs for a while then goes kaboom)

(gdb) where

(here is the valuable output to send in)

(gdb) quit

Thanks!

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message